]> git.pond.sub.org Git - empserver/blobdiff - src/client/configure.ac
Update copyright notice
[empserver] / src / client / configure.ac
index 1b2ae3076305cd2fdb6f3f31e03725ab1d56083c..3e75ed48a94ca8c559eb7cb71aa815bb3a07879a 100644 (file)
@@ -1,35 +1,34 @@
-# 
+#
 #   Empire - A multi-player, client/server Internet based war game.
-#   Copyright (C) 1986-2006, Dave Pare, Jeff Bailey, Thomas Ruschak,
-#                            Ken Stevens, Steve McClure
-# 
-#   This program is free software; you can redistribute it and/or modify
+#   Copyright (C) 1986-2014, Dave Pare, Jeff Bailey, Thomas Ruschak,
+#                 Ken Stevens, Steve McClure, Markus Armbruster
+#
+#   Empire is free software: you can redistribute it and/or modify
 #   it under the terms of the GNU General Public License as published by
-#   the Free Software Foundation; either version 2 of the License, or
+#   the Free Software Foundation, either version 3 of the License, or
 #   (at your option) any later version.
-# 
+#
 #   This program is distributed in the hope that it will be useful,
 #   but WITHOUT ANY WARRANTY; without even the implied warranty of
 #   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 #   GNU General Public License for more details.
-# 
+#
 #   You should have received a copy of the GNU General Public License
-#   along with this program; if not, write to the Free Software
-#   Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
-# 
+#   along with this program.  If not, see <http://www.gnu.org/licenses/>.
+#
 #   ---
-# 
+#
 #   See files README, COPYING and CREDITS in the root of the source
 #   tree for related information and legal notices.  It is expected
 #   that future projects/authors will amend these files as needed.
-# 
+#
 #   ---
-# 
+#
 #   configure.ac: Autoconf input file
-#  
+#
 #   Known contributors to this file:
-#      Markus Armbruster, 2005
-# 
+#      Markus Armbruster, 2005-2013
+#
 # Process this file with autoconf to produce a configure script.
 
 # Autoconf makes checking for and programming around assorted ancient
@@ -37,8 +36,9 @@
 # POSIX, and when something breaks on some oddball machine, see
 # whether it's worth fixing.
 
-AC_PREREQ(2.59)
-AC_INIT([Empire Client], [4.3.7], [wolfpack@wolfpackempire.com])
+AC_PREREQ(2.64)
+AC_INIT([Empire Client], [4.3.32], [wolfpack@wolfpackempire.com],,
+       [http://www.wolfpackempire.com/])
 AC_CONFIG_SRCDIR([empire.6])
 AC_CONFIG_HEADERS([config.h])
 
@@ -47,32 +47,33 @@ AC_CONFIG_HEADERS([config.h])
 AC_PROG_CC
 AC_PROG_INSTALL
 
+# Not a program, but need to check this early
+MY_WINDOWS_API
+
 
 ### Checks for libraries.
-AC_SEARCH_LIBS([setupterm], [termlib termcap curses ncurses])
-LIB_SOCKET_NSL
-# TODO merge this into LIB_SOCKET_NSL?
-if test "$ac_cv_search_gethostbyname" = no; then
-    dnl Can't search ws2_32 for gethostbyname using AC_SEARCH_LIBS, because
-    dnl it requires #include <winsock2.h> to work.
-    AC_MSG_CHECKING([for gethostbyname in -lws2_32])
-    save_LIBS=$LIBS
-    LIBS="-lws2_32 $LIBS"
-    AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <winsock2.h>]],
-                                   [[gethostbyname ("");]])],
-                  [ws2_res=yes], [LIBS=save_LIBS ws2_res=no])
-    AC_MSG_RESULT([$ws2_res])
+LIBS="$LIBS_SOCKETS $LIBS"
+AX_LIB_SOCKET_NSL
+if test "$Windows_API" = yes; then
+       AC_LIBOBJ([w32/w32io])
+       AC_LIBOBJ([w32/w32sockets])
 fi
 
+
 ### Checks for header files.
 
 
 ### Checks for typedefs, structures, and compiler characteristics.
 
+if test "$Windows_API" = yes; then
+       CPPFLAGS="$CPPFLAGS -Iw32"
+       CFLAGS="$CFLAGS -mthreads"
+fi
+
 
 ### Checks for library functions.
 
-AC_CHECK_FUNCS(getaddrinfo)
+AC_CHECK_FUNCS(getaddrinfo getpass)
 
 
 ### Site configuration
@@ -83,8 +84,15 @@ test "$EMPIREHOST" || EMPIREHOST=blitz.wolfpackempire.com
 AC_ARG_VAR([EMPIREPORT], [Default port [6789]])
 test "$EMPIREPORT" || EMPIREPORT=6789
 
+MY_WITH_TERMINFO
 
 ### Output
 
 AC_CONFIG_FILES([Makefile ipglob.c])
 AC_OUTPUT
+
+AC_MSG_NOTICE([])
+AC_MSG_NOTICE([-= Configuration summary =-])
+AC_MSG_NOTICE([      terminfo: $with_terminfo])
+AC_MSG_NOTICE([    EMPIREHOST: $EMPIREHOST])
+AC_MSG_NOTICE([    EMPIREPORT: $EMPIREPORT])