]> git.pond.sub.org Git - empserver/blobdiff - src/client/configure.ac
Update copyright notice.
[empserver] / src / client / configure.ac
index e2b38e3741b3d17b4e93402c6a6263769a881f74..4303bbabf31ba11228627ec651af36d18d3a899e 100644 (file)
@@ -1,5 +1,35 @@
-#                                               -*- Autoconf -*-
-# Copyright (C) 2005 Markus Armbruster
+# 
+#   Empire - A multi-player, client/server Internet based war game.
+#   Copyright (C) 1986-2007, Dave Pare, Jeff Bailey, Thomas Ruschak,
+#                            Ken Stevens, Steve McClure
+# 
+#   This program is free software; you can redistribute it and/or modify
+#   it under the terms of the GNU General Public License as published by
+#   the Free Software Foundation; either version 2 of the License, or
+#   (at your option) any later version.
+# 
+#   This program is distributed in the hope that it will be useful,
+#   but WITHOUT ANY WARRANTY; without even the implied warranty of
+#   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+#   GNU General Public License for more details.
+# 
+#   You should have received a copy of the GNU General Public License
+#   along with this program; if not, write to the Free Software
+#   Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+# 
+#   ---
+# 
+#   See files README, COPYING and CREDITS in the root of the source
+#   tree for related information and legal notices.  It is expected
+#   that future projects/authors will amend these files as needed.
+# 
+#   ---
+# 
+#   configure.ac: Autoconf input file
+#  
+#   Known contributors to this file:
+#      Markus Armbruster, 2005
+# 
 # Process this file with autoconf to produce a configure script.
 
 # Autoconf makes checking for and programming around assorted ancient
@@ -8,7 +38,7 @@
 # whether it's worth fixing.
 
 AC_PREREQ(2.59)
-AC_INIT([Empire Client], [4.3.0], [wolfpack@wolfpackempire.com])
+AC_INIT([Empire Client], [4.3.10], [wolfpack@wolfpackempire.com])
 AC_CONFIG_SRCDIR([empire.6])
 AC_CONFIG_HEADERS([config.h])
 
@@ -19,14 +49,20 @@ AC_PROG_INSTALL
 
 
 ### Checks for libraries.
+AC_SEARCH_LIBS([setupterm], [termlib termcap curses ncurses])
 LIB_SOCKET_NSL
-AC_SEARCH_LIBS([setupterm], [termlib termcap])
 # TODO merge this into LIB_SOCKET_NSL?
-case "$host_os" in
-*mingw32)
-    LIBS="-lws2_32 $LIBS" ;;
-esac
-
+if test "$ac_cv_search_gethostbyname" = no; then
+    dnl Can't search ws2_32 for gethostbyname using AC_SEARCH_LIBS, because
+    dnl it requires #include <winsock2.h> to work.
+    AC_MSG_CHECKING([for gethostbyname in -lws2_32])
+    save_LIBS=$LIBS
+    LIBS="-lws2_32 $LIBS"
+    AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <winsock2.h>]],
+                                   [[gethostbyname ("");]])],
+                  [ws2_res=yes], [LIBS=save_LIBS ws2_res=no])
+    AC_MSG_RESULT([$ws2_res])
+fi
 
 ### Checks for header files.