]> git.pond.sub.org Git - empserver/blobdiff - src/client/configure.ac
Fix build for systems that don't provide POSIX.1-2001 by default
[empserver] / src / client / configure.ac
index e7e373adb9da59e065124964f6d589f305aebfa4..76268544322adde27c317a22fb4dc67e6bab886d 100644 (file)
@@ -1,11 +1,11 @@
 #
 #   Empire - A multi-player, client/server Internet based war game.
-#   Copyright (C) 1986-2009, Dave Pare, Jeff Bailey, Thomas Ruschak,
-#                            Ken Stevens, Steve McClure
+#   Copyright (C) 1986-2020, Dave Pare, Jeff Bailey, Thomas Ruschak,
+#                 Ken Stevens, Steve McClure, Markus Armbruster
 #
-#   This program is free software; you can redistribute it and/or modify
+#   Empire is free software: you can redistribute it and/or modify
 #   it under the terms of the GNU General Public License as published by
-#   the Free Software Foundation; either version 2 of the License, or
+#   the Free Software Foundation, either version 3 of the License, or
 #   (at your option) any later version.
 #
 #   This program is distributed in the hope that it will be useful,
@@ -14,8 +14,7 @@
 #   GNU General Public License for more details.
 #
 #   You should have received a copy of the GNU General Public License
-#   along with this program; if not, write to the Free Software
-#   Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+#   along with this program.  If not, see <http://www.gnu.org/licenses/>.
 #
 #   ---
 #
@@ -28,7 +27,7 @@
 #   configure.ac: Autoconf input file
 #
 #   Known contributors to this file:
-#      Markus Armbruster, 2005-2008
+#      Markus Armbruster, 2005-2020
 #
 # Process this file with autoconf to produce a configure script.
 
 # POSIX, and when something breaks on some oddball machine, see
 # whether it's worth fixing.
 
-AC_PREREQ(2.59)
-AC_INIT([Empire Client], [4.3.20], [wolfpack@wolfpackempire.com])
+AC_PREREQ(2.69)
+AC_INIT([Wolfpack Empire Client],
+       m4_esyscmd([cat .tarball-version]),
+       [wolfpack@wolfpackempire.com],,
+       [http://www.wolfpackempire.com/])
 AC_CONFIG_SRCDIR([empire.6])
 AC_CONFIG_HEADERS([config.h])
 
+AC_DEFINE([_XOPEN_SOURCE], [600],
+         [Request POSIX-1.2001 with XSI Extension])
+
 
 ### Checks for programs.
 AC_PROG_CC
 AC_PROG_INSTALL
 
+# Not a program, but need to check this early
+MY_WINDOWS_API
+
 
 ### Checks for libraries.
-AC_SEARCH_LIBS([setupterm], [termlib termcap curses ncurses])
-LIB_SOCKET_NSL
-# TODO merge this into LIB_SOCKET_NSL?
-if test "$ac_cv_search_gethostbyname" = no; then
-    dnl Can't search ws2_32 for gethostbyname using AC_SEARCH_LIBS, because
-    dnl it requires #include <winsock2.h> to work.
-    AC_MSG_CHECKING([for gethostbyname in -lws2_32])
-    save_LIBS=$LIBS
-    LIBS="-lws2_32 $LIBS"
-    AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <winsock2.h>]],
-                                   [[gethostbyname ("");]])],
-                  [ws2_res=yes], [LIBS=save_LIBS ws2_res=no])
-    AC_MSG_RESULT([$ws2_res])
+LIBS="$LIBS_SOCKETS $LIBS"
+AX_LIB_SOCKET_NSL
+if test "$Windows_API" = yes; then
+       AC_LIBOBJ([w32/w32io])
+       AC_LIBOBJ([w32/w32sockets])
 fi
+MY_WITH_READLINE
+
 
 ### Checks for header files.
 
 
 ### Checks for typedefs, structures, and compiler characteristics.
 
-AC_MSG_CHECKING([for Windows])
-AC_COMPILE_IFELSE(
-    [AC_LANG_SOURCE([[#ifdef _WIN32
-#Here's a nickel, kid
-#endif]])],
-    [Windows_res=no],
-    [Windows_res=yes CFLAGS="$CFLAGS -mthreads"])
-AC_MSG_RESULT([$Windows_res])
+if test "$Windows_API" = yes; then
+       CPPFLAGS="$CPPFLAGS -Iw32"
+       CFLAGS="$CFLAGS -mthreads"
+fi
 
 
 ### Checks for library functions.
@@ -92,8 +90,18 @@ test "$EMPIREHOST" || EMPIREHOST=blitz.wolfpackempire.com
 AC_ARG_VAR([EMPIREPORT], [Default port [6789]])
 test "$EMPIREPORT" || EMPIREPORT=6789
 
+MY_WITH_TERMINFO
 
 ### Output
 
+AC_DEFINE_UNQUOTED(VERSION, "`cat $srcdir/.tarball-version`", [Tarball version])
+
 AC_CONFIG_FILES([Makefile ipglob.c])
 AC_OUTPUT
+
+AC_MSG_NOTICE([])
+AC_MSG_NOTICE([-= Configuration summary =-])
+AC_MSG_NOTICE([      readline: $with_readline])
+AC_MSG_NOTICE([      terminfo: $with_terminfo])
+AC_MSG_NOTICE([    EMPIREHOST: $EMPIREHOST])
+AC_MSG_NOTICE([    EMPIREPORT: $EMPIREPORT])