]> git.pond.sub.org Git - empserver/blobdiff - src/client/configure.ac
Use src/lib/w32/w32io.c for client
[empserver] / src / client / configure.ac
index 7a38f4393e413db025a9b1e4343b3c5bb1aaa1f3..9625e435f213792518c77b886e53cfbe3a0a95ff 100644 (file)
@@ -54,6 +54,9 @@ MY_WINDOWS_API
 ### Checks for libraries.
 LIBS="$LIBS_SOCKETS $LIBS"
 LIB_SOCKET_NSL
+if test "$Windows_API" = yes; then
+       AC_LIBOBJ([w32/w32io])
+fi
 
 
 ### Checks for header files.
@@ -62,6 +65,7 @@ LIB_SOCKET_NSL
 ### Checks for typedefs, structures, and compiler characteristics.
 
 if test "$Windows_API" = yes; then
+       CPPFLAGS="$CPPFLAGS -Iw32"
        CFLAGS="$CFLAGS -mthreads"
 fi