]> git.pond.sub.org Git - empserver/blobdiff - src/client/configure.ac
Merge branch 'readline'
[empserver] / src / client / configure.ac
index 2baebcad007060219fff2ed0b1d82038db099822..f529d721d8802479b35314dfac46fe05cbea54c6 100644 (file)
@@ -1,6 +1,6 @@
 #
 #   Empire - A multi-player, client/server Internet based war game.
-#   Copyright (C) 1986-2015, Dave Pare, Jeff Bailey, Thomas Ruschak,
+#   Copyright (C) 1986-2016, Dave Pare, Jeff Bailey, Thomas Ruschak,
 #                 Ken Stevens, Steve McClure, Markus Armbruster
 #
 #   Empire is free software: you can redistribute it and/or modify
@@ -27,7 +27,7 @@
 #   configure.ac: Autoconf input file
 #
 #   Known contributors to this file:
-#      Markus Armbruster, 2005-2015
+#      Markus Armbruster, 2005-2016
 #
 # Process this file with autoconf to produce a configure script.
 
 # POSIX, and when something breaks on some oddball machine, see
 # whether it's worth fixing.
 
-AC_PREREQ(2.64)
-AC_INIT([Empire Client], [4.3.34], [wolfpack@wolfpackempire.com],,
+AC_PREREQ(2.69)
+AC_INIT([Wolfpack Empire Client],
+       m4_esyscmd([cat .tarball-version]),
+       [wolfpack@wolfpackempire.com],,
        [http://www.wolfpackempire.com/])
 AC_CONFIG_SRCDIR([empire.6])
 AC_CONFIG_HEADERS([config.h])
@@ -89,6 +91,8 @@ MY_WITH_TERMINFO
 
 ### Output
 
+AC_DEFINE_UNQUOTED(VERSION, "`cat .tarball-version`", [Tarball version])
+
 AC_CONFIG_FILES([Makefile ipglob.c])
 AC_OUTPUT